check-hash: silence hash ok messages when make -s is used
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 24 Oct 2014 23:42:49 +0000 (01:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 24 Oct 2014 23:42:49 +0000 (01:42 +0200)
Similar to what we do for apply-patches.sh

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk

index 0cf0b63d81dd8af5d679a35a5be38b55ef0e194f..f3409bd46ea5f683cbe3cc87dafed40d5322964f 100644 (file)
@@ -63,7 +63,7 @@ github = https://github.com/$(1)/$(2)/archive/$(3)
 # $(1): the path to the file with the hashes
 # $(2): the full path to the file to check
 define VERIFY_HASH
-       if ! support/download/check-hash $(1) $(2); then \
+       if ! support/download/check-hash $(1) $(2) $(if $(QUIET),>/dev/null); then \
                rm -f $(2); \
                exit 1; \
        fi