Add a show-targets target
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 May 2010 17:20:33 +0000 (19:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 21 May 2010 13:07:34 +0000 (15:07 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index a4bf4b570e9fcd73bcfca7e60d3d485d0b9f825c..ec2ec36ab7f807d1b2320780d545b109b577d1f5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -449,6 +449,9 @@ external-deps:
        @$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
                SPIDER=--spider source
 
+show-targets:
+       @echo $(TARGETS)
+
 ifeq ($(BR2_CONFIG_CACHE),y)
 # drop configure cache if configuration is changed
 $(BUILD_DIR)/tgt-config.cache: .config