rsh-redone: enable rshd and rlogind
authorAndreas Ehmanns <universeii@gmx.de>
Mon, 18 Nov 2013 14:34:45 +0000 (15:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Apr 2014 15:10:15 +0000 (17:10 +0200)
[Thomas: add dependency on linux-pam for rshd and rlogind, adjust
commit message.]

Signed-off-by Andreas Ehmanns <universeii@gmx.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsh-redone/Config.in
package/rsh-redone/rsh-redone.mk

index 5a9036278e5a2ddbc9c9eed8038c3899ee63b920..d26ca2baeb80aae47e5da5396947d325d1e304e5 100644 (file)
@@ -16,15 +16,23 @@ if BR2_PACKAGE_RSH_REDONE
 config BR2_PACKAGE_RSH_REDONE_RLOGIN
        bool "rlogin"
 
-# requires PAM
-#config BR2_PACKAGE_RSH_REDONE_RLOGIND
-#      bool "rlogind"
+config BR2_PACKAGE_RSH_REDONE_RLOGIND
+       bool "rlogind"
+       select BR2_PACKAGE_LINUX_PAM
+       depends on BR2_ENABLE_LOCALE && BR2_USE_WCHAR
+
+comment "rlogind needs a toolchain w/ wchar, locale"
+       depends on !(BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
 
 config BR2_PACKAGE_RSH_REDONE_RSH
        bool "rsh"
 
-# requires PAM
-#config BR2_PACKAGE_RSH_REDONE_RSHD
-#      bool "rshd"
+config BR2_PACKAGE_RSH_REDONE_RSHD
+       bool "rshd"
+       select BR2_PACKAGE_LINUX_PAM
+       depends on BR2_ENABLE_LOCALE && BR2_USE_WCHAR
+
+comment "rshd needs a toolchain w/ wchar, locale"
+       depends on !(BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
 
 endif
index c7d3b7ad3978935546f0d1f01be93ec3e76db6a7..93e1358b6668fd4da0ddf56db94daf3342071525 100644 (file)
@@ -13,8 +13,12 @@ rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RCP) += rcp
 rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RLOGIN) += rlogin
 rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RSH) += rsh
 rsh-redone-sbin-y =
-rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += rlogind
-rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += rshd
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += in.rlogind
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += in.rshd
+
+ifneq ($(BR2_PACKAGE_RSH_REDONE_RSHD)$(BR2_PACKAGE_RSH_REDONE_RLOGIND),)
+RSH_REDONE_DEPENDENCIES = linux-pam
+endif
 
 define RSH_REDONE_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) BIN="$(rsh-redone-bin-y)" SBIN="$(rsh-redone-sbin-y)"