apr: fix threading lib detection
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 27 Nov 2013 12:53:04 +0000 (09:53 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Nov 2013 13:41:18 +0000 (14:41 +0100)
apr's configure doesn't try to guess which library is needed for
threading when cross-compiling hence this is never reflected in
apr-1-config, leading to a build failure such as:
http://autobuild.buildroot.net/results/035/035a00de0a56be00559767ba822a396ddc18a9fb/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/apr/apr.mk

index 4da42c5b9f0a4eb87c33bca80e10b361c8789e99..1a4c0e261bdfe0b0e04a967f4730ce5a4c9d8deb 100644 (file)
@@ -19,6 +19,11 @@ APR_CONF_ENV = \
        apr_cv_mutex_recursive=yes
 APR_CONFIG_SCRIPTS = apr-1-config
 
+# Doesn't even try to guess when cross compiling
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+APR_CONF_ENV += apr_cv_pthreads_lib="-lpthread"
+endif
+
 define APR_CLEANUP_UNNEEDED_FILES
        $(RM) -rf $(TARGET_DIR)/usr/build-1/
 endef