libsoc: add new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 12 Sep 2013 07:05:36 +0000 (09:05 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 12 Sep 2013 20:30:18 +0000 (22:30 +0200)
[Peter: fix help text, doesn't need fork, file header, license tags]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libsoc/Config.in [new file with mode: 0644]
package/libsoc/libsoc.mk [new file with mode: 0644]

index 02e5afceba4566b940e81032b082a1e5c75b4370..0d457a6208a02693fc698c3ac2a6d9e31547184c 100644 (file)
@@ -542,6 +542,7 @@ source "package/libnfc/Config.in"
 source "package/libnfc-llcp/Config.in"
 source "package/libqmi/Config.in"
 source "package/libserial/Config.in"
+source "package/libsoc/Config.in"
 source "package/libusb/Config.in"
 source "package/libusb-compat/Config.in"
 source "package/libv4l/Config.in"
diff --git a/package/libsoc/Config.in b/package/libsoc/Config.in
new file mode 100644 (file)
index 0000000..3e750bd
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBSOC
+       bool "libsoc"
+       help
+         libsoc is a C library for interfacing with common SoC
+         peripherals through generic kernel interfaces
+
+         https://github.com/jackmitch/libsoc
diff --git a/package/libsoc/libsoc.mk b/package/libsoc/libsoc.mk
new file mode 100644 (file)
index 0000000..f310266
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libsoc
+#
+################################################################################
+
+LIBSOC_VERSION = 356760dcb93b22d6c67c5232cde2ade8c968c932
+LIBSOC_SITE = http://github.com/jackmitch/libsoc/tarball/$(LIBSOC_VERSION)
+LIBSOC_LICENSE = LGPLv2.1
+LIBSOC_LICENSE_FILES = COPYING
+LIBSOC_AUTORECONF = YES
+LIBSOC_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))
+