package/docker-cli: define <pkg>_GOMOD variable
authorChristian Stewart <christian@paral.in>
Sat, 29 Aug 2020 09:44:33 +0000 (11:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 12:35:49 +0000 (14:35 +0200)
In preparation for the go.mod integration, define the DOCKER_CLI_GOMOD
variable.

We also use it as a handy shortcut when defining DOCKER_CLI_LDFLAGS.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/docker-cli/docker-cli.mk

index 1466b0afbdc2b315c4d736318f26a19417ac9525..9ef1270137dad9ca5734cae334f896b2cd89bda9 100644 (file)
@@ -15,10 +15,11 @@ DOCKER_CLI_DEPENDENCIES = host-pkgconf
 
 DOCKER_CLI_TAGS = autogen
 DOCKER_CLI_BUILD_TARGETS = cmd/docker
+DOCKER_CLI_GOMOD = github.com/docker/cli
 
 DOCKER_CLI_LDFLAGS = \
-       -X github.com/docker/cli/cli.GitCommit=$(DOCKER_CLI_VERSION) \
-       -X github.com/docker/cli/cli.Version=$(DOCKER_CLI_VERSION)
+       -X $(DOCKER_CLI_GOMOD)/cli.GitCommit=$(DOCKER_CLI_VERSION) \
+       -X $(DOCKER_CLI_GOMOD)/cli.Version=$(DOCKER_CLI_VERSION)
 
 ifeq ($(BR2_PACKAGE_DOCKER_CLI_STATIC),y)
 DOCKER_CLI_LDFLAGS += -extldflags '-static'