package/binutils: add C-SKY specific version
authorGuo Ren <ren_guo@c-sky.com>
Fri, 31 May 2019 06:39:03 +0000 (14:39 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 31 May 2019 20:59:57 +0000 (22:59 +0200)
Signed-off-by: Guo Ren <ren_guo@c-sky.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/binutils/Config.in.host
package/binutils/binutils.hash
package/binutils/binutils.mk

index 52b0ea22e7a5e8cfdc0d3539536483d3999a8296..d9b34d7a9b88b5d4e23a6ab4d5f712b243027cc5 100644 (file)
@@ -7,28 +7,38 @@ config BR2_PACKAGE_HOST_BINUTILS_SUPPORTS_CFI
 
 choice
        prompt "Binutils Version"
-       default BR2_BINUTILS_VERSION_2_31_X if !BR2_arc
+       default BR2_BINUTILS_VERSION_2_31_X if !BR2_arc && !BR2_csky
        default BR2_BINUTILS_VERSION_ARC if BR2_arc
+       default BR2_BINUTILS_VERSION_CSKY if BR2_csky
        help
          Select the version of binutils you wish to use.
 
 config BR2_BINUTILS_VERSION_2_30_X
        bool "binutils 2.30"
+       depends on !BR2_csky
 
 config BR2_BINUTILS_VERSION_2_31_X
        bool "binutils 2.31.1"
+       depends on !BR2_csky
 
 config BR2_BINUTILS_VERSION_2_32_X
        bool "binutils 2.32"
+       depends on !BR2_csky
 
 config BR2_BINUTILS_VERSION_ARC
        bool "binutils arc (2.31)"
        depends on BR2_arc
+
+config BR2_BINUTILS_VERSION_CSKY
+       bool "binutils csky"
+       depends on BR2_csky
+
 endchoice
 
 config BR2_BINUTILS_VERSION
        string
        default "arc-2019.03-rc1"       if BR2_BINUTILS_VERSION_ARC
+       default "c66d8bbcebfddf713b2b436e1b135e6b125a55a5" if BR2_BINUTILS_VERSION_CSKY
        default "2.30"          if BR2_BINUTILS_VERSION_2_30_X
        default "2.31.1"        if BR2_BINUTILS_VERSION_2_31_X
        default "2.32"          if BR2_BINUTILS_VERSION_2_32_X
index 4792208e45f7e5541c9940140a11b6d146e65c82..125372cc6fff0e69e29528d4a9b73fbaf192176b 100644 (file)
@@ -5,3 +5,6 @@ sha512  d326408f12a03d9a61a9de56584c2af12f81c2e50d2d7e835d51565df8314df01575724a
 
 # Locally calculated (fetched from Github)
 sha512  ceb0546cb73a29526f2f8916d855fbed52b2fc86b6706687cabf57b96df06932714820edec2f9038529790e7925304778ded0944babc985a39371eb08c6c7f52  binutils-gdb-arc-2019.03-rc1.tar.gz
+
+# Locally calculated (fetched from https://github.com/c-sky/binutils-gdb)
+sha512  979552d4b3a4f31e9f3b9a7027321bd4eb3ac6c2d8deac1720e94e54f81d736db09c53c5d87c301010e307b64127e14400a036c7a35e5d63a954a4edd9cc8e2c  binutils-c66d8bbcebfddf713b2b436e1b135e6b125a55a5.tar.gz
index 0b06f49d72b7876098604555068cac46b731627c..edb4be186921b726fef45ec80f7f61ba310a3b34 100644 (file)
@@ -20,6 +20,13 @@ BINUTILS_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils-gdb,
 BINUTILS_SOURCE = binutils-gdb-$(BINUTILS_VERSION).tar.gz
 BINUTILS_FROM_GIT = y
 endif
+
+ifeq ($(BR2_csky),y)
+BINUTILS_SITE = $(call github,c-sky,binutils-gdb,$(BINUTILS_VERSION))
+BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
+BINUTILS_FROM_GIT = y
+endif
+
 BINUTILS_SITE ?= $(BR2_GNU_MIRROR)/binutils
 BINUTILS_SOURCE ?= binutils-$(BINUTILS_VERSION).tar.xz
 BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))