qt5quickcontrols: More deterministic target install
authorNaumann Andreas <ANaumann@ultratronik.de>
Tue, 31 Jan 2017 07:59:08 +0000 (08:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Feb 2017 16:46:48 +0000 (17:46 +0100)
Restrict target install to quickcontrols(1) qmls only.

Installing everything under qml/QtQuick includes e.g. quickcontrols2 if
existent in staging (but not selected). Another issue may arise e.g. for a
external package that creates more files than it installs itself under
qml/QtQuick. In that case, it would depend on the order of the packages how
much gets installed into target.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5quickcontrols/qt5quickcontrols.mk

index b33ff1575eb8bf5e33cf9fe23ea0a50a82153364..c2946bc753bf5e1b0a7865c63e71cae39d64843e 100644 (file)
@@ -31,7 +31,10 @@ define QT5QUICKCONTROLS_INSTALL_STAGING_CMDS
 endef
 
 define QT5QUICKCONTROLS_INSTALL_TARGET_CMDS
-       cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick $(TARGET_DIR)/usr/qml
+       cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/Controls $(TARGET_DIR)/usr/qml/QtQuick
+       cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/Dialogs $(TARGET_DIR)/usr/qml/QtQuick
+       cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/Extras $(TARGET_DIR)/usr/qml/QtQuick
+       cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/PrivateWidgets $(TARGET_DIR)/usr/qml/QtQuick
 endef
 
 $(eval $(generic-package))