package/systemd-bootchart: enable systemd-bootchart.service
authorJames Hilliard <james.hilliard1@gmail.com>
Tue, 3 Sep 2019 21:28:12 +0000 (15:28 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 17 Sep 2019 21:14:27 +0000 (23:14 +0200)
This would normally be enabled by systemctl preset-all however since we
don't have a host systemctl we need to enable the service manually.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd-bootchart/systemd-bootchart.mk

index bcc3dbe22af2510cfce13fe90e3d6bbe36fe5981..62bc79539b1ac6f3828c0105f08b562d1f1daec7 100644 (file)
@@ -16,4 +16,10 @@ SYSTEMD_BOOTCHART_DEPENDENCIES = systemd
 
 SYSTEMD_BOOTCHART_CONF_OPTS = --disable-man
 
+define SYSTEMD_BOOTCHART_INSTALL_INIT_SYSTEMD
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/sysinit.target.wants
+       ln -sf ../../../../lib/systemd/system/systemd-bootchart.service \
+               $(TARGET_DIR)/etc/systemd/system/sysinit.target.wants/systemd-bootchart.service
+endef
+
 $(eval $(autotools-package))