- make absolutely sure that we are not trying to go into jobserver mode for MAKE1
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 30 Jan 2007 17:33:53 +0000 (17:33 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 30 Jan 2007 17:33:53 +0000 (17:33 -0000)
package/Makefile.in

index aca3e4b07aa4365140ae575c1a857fe76873a183..f8557f7007ae6d91f2850fa4de133263400707d7 100644 (file)
@@ -1,5 +1,8 @@
-MAKE1=make
-MAKE=make -j$(BR2_JLEVEL)
+ifndef MAKE
+MAKE=make
+endif
+MAKE1:=$(MAKE) MAKE="$(firstword $(MAKE)) -j1"
+MAKE:=$(MAKE) -j$(BR2_JLEVEL)
 
 # Strip off the annoying quoting
 ARCH:=$(strip $(subst ",, $(BR2_ARCH)))