package/vlc: use pkgconf to find live555 libraries
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 18 Aug 2018 18:22:57 +0000 (20:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 21:21:48 +0000 (23:21 +0200)
Some live555 libraries were missing in LIVE555_LIBS.
Instead of maintaining the list of live555 library files we use pkgconf
instead.

Fixes
http://autobuild.buildroot.net/results/744/7445bdc2fdcb28aa7f58c0249653329414e447df/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index ed682e60b3cfa788116669bdd873672210d54f45..d4be8b0bf13754ed714410c4c66916b6342be748 100644 (file)
@@ -427,14 +427,6 @@ endif
 ifeq ($(BR2_PACKAGE_LIVE555),y)
 VLC_CONF_OPTS += --enable-live555
 VLC_DEPENDENCIES += live555
-VLC_CONF_ENV += \
-       LIVE555_CFLAGS="\
-               -I$(STAGING_DIR)/usr/include/BasicUsageEnvironment \
-               -I$(STAGING_DIR)/usr/include/groupsock \
-               -I$(STAGING_DIR)/usr/include/liveMedia \
-               -I$(STAGING_DIR)/usr/include/UsageEnvironment \
-               " \
-       LIVE555_LIBS="-L$(STAGING_DIR)/usr/lib -lliveMedia"
 else
 VLC_CONF_OPTS += --disable-live555
 endif