x11vnc: add libXtst as a dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Sep 2012 18:40:39 +0000 (20:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Sep 2012 18:40:39 +0000 (20:40 +0200)
x11vnc CAN be built without XTEST support, but it isn't very useful as
noted by the warning printed by configure when it isn't found:

*** A working build environment for the XTEST extension was not found ***
(libXtst).  An x11vnc built this way will be *ONLY BARELY USABLE*.
You will be able to move the mouse but not click or type.  There can
also be deadlocks if an application grabs the X server.

It is recommended that you install the necessary development packages
for XTEST (perhaps it is named something like libxtst-dev) and run
configure again.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11vnc/Config.in
package/x11vnc/x11vnc.mk

index 53895b087eb346f5880a7e1ad786262d231c127c..5693754bf2b597e118dc31adcb46a453001eb59c 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_X11VNC
        depends on BR2_PACKAGE_XORG7
        select BR2_PACKAGE_XLIB_LIBXT
        select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_XLIB_LIBXTST
        help
          VNC server for X11 display
 
index 51ae0a0fb20f29189acbfc23d8a52f5a788f268a..06afcac8d6a8fcf30142aefe177e0931fd4362f8 100644 (file)
@@ -9,7 +9,7 @@ X11VNC_SITE = http://downloads.sourceforge.net/project/libvncserver/x11vnc/$(X11
 X11VNC_CONF_OPT = \
        --without-avahi
 
-X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext
+X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext xlib_libXtst
 
 ifneq ($(BR2_INET_IPV6),y)
 # configure option only used for libvncserver