fluxbox: add xsession profile
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 10 Oct 2011 09:21:58 +0000 (11:21 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 7 Dec 2011 20:11:57 +0000 (21:11 +0100)
add .xsession profile to get fluxbox being started automatically
by XDM.

[Peter: Only install if not available in skeleton, use install -D,
Make it an executable script and don't hide it]
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/fluxbox/fluxbox.mk
package/fluxbox/xsession [new file with mode: 0644]

index 85a8eae41c456412d061a312ccf0c55d4430204c..5a123f0e9c9c94c486e4470975fbc444156c6424 100644 (file)
@@ -13,4 +13,11 @@ FLUXBOX_CONF_OPT = --x-includes=$(STAGING_DIR)/usr/include/X11 \
 
 FLUXBOX_DEPENDENCIES = xlib_libX11 $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
+define FLUXBOX_INSTALL_XSESSION_FILE
+       [ -f $(TARGET_DIR)/root/.xsession ] || $(INSTALL) -m 0755 -D \
+               package/fluxbox/xsession $(TARGET_DIR)/root/.xsession
+endef
+
+FLUXBOX_POST_INSTALL_TARGET_HOOKS += FLUXBOX_INSTALL_XSESSION_FILE
+
 $(eval $(call AUTOTARGETS))
diff --git a/package/fluxbox/xsession b/package/fluxbox/xsession
new file mode 100644 (file)
index 0000000..b51acff
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec startfluxbox