mplayer: switch it to samba4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 11 Mar 2016 14:32:18 +0000 (11:32 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Mar 2016 21:42:12 +0000 (22:42 +0100)
samba(3) has been deprecated for quite some time so switch mplayer to
use samba4 if available.
It needs a little extra tweak to pick up the proper cflags since the odd
configure script doesn't do it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mplayer/mplayer.mk

index 2082f2519061d87c2f6c038e14c59882771ac85d..cbbd1e772816a55791593f58a1da035c0bcfb779 100644 (file)
@@ -98,9 +98,11 @@ else
 MPLAYER_CONF_OPTS += --disable-termcap
 endif
 
-ifeq ($(BR2_PACKAGE_SAMBA_SMBCLIENT),y)
+# mplayer doesn't pick up libsmbclient cflags
+ifeq ($(BR2_PACKAGE_SAMBA4),y)
+MPLAYER_CFLAGS += `$(PKG_CONFIG_HOST_BINARY) --cflags smbclient`
 MPLAYER_CONF_OPTS += --enable-smb
-MPLAYER_DEPENDENCIES += samba
+MPLAYER_DEPENDENCIES += samba4
 else
 MPLAYER_CONF_OPTS += --disable-smb
 endif