package/swupdate: disable lua in static build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 11 Jan 2019 14:33:12 +0000 (15:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 12 Jan 2019 13:50:24 +0000 (14:50 +0100)
Since version 2018.11 and
https://github.com/sbabic/swupdate/commit/624904cc18003fae413011563dac83a333f10509,
bindings for LUA is a shared library so disable lua if BR2_STATIC_LIBS
is set

Fixes:
 - http://autobuild.buildroot.org/results/55767e58c211656558af7916a4e0975089a2785b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/swupdate/swupdate.mk

index 08d6ba9372fb0d7b2f6a89a445deb22496a0a37e..b7ef09c924d8dec2e96771fdf5c6d52e8c48e3df 100644 (file)
@@ -44,7 +44,7 @@ else
 SWUPDATE_MAKE_ENV += HAVE_LIBCURL=n
 endif
 
-ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
+ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER):$(BR2_STATIC_LIBS),y:)
 SWUPDATE_DEPENDENCIES += luainterpreter host-pkgconf
 # defines the base name for the pkg-config file ("lua" or "luajit")
 define SWUPDATE_SET_LUA_VERSION