gtksourceview: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 29 Jul 2016 07:51:28 +0000 (09:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 30 Jul 2016 13:51:39 +0000 (15:51 +0200)
GtkSourceView is a portable C library that extends the
standard GTK+ framework for multiline text editing with
support for configurable syntax highlighting, unlimited
undo/redo, search and replace, a completion framework,
printing and other features typical of a source code editor.

https://projects.gnome.org/gtksourceview

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
[Thomas:
 - simplify the Config.in by using "depends on BR2_PACKAGE_LIBGTK3"
   instead of a select. It is pretty obvious that Gtk is needed if you
   want to use gtksourceview.
 - license is LGPLv2.1+, not LGPLv2+.
 - change location in package/Config.in, gtksourceview is a library,
   it should not go under "Development tools".]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/gtksourceview/Config.in [new file with mode: 0644]
package/gtksourceview/gtksourceview.hash [new file with mode: 0644]
package/gtksourceview/gtksourceview.mk [new file with mode: 0644]

index 5584d36df60eb259bb300e888379053776695637..875d7556445f3a40ed43a4101a1622ce76faf298 100644 (file)
@@ -938,6 +938,7 @@ menu "Graphics"
        source "package/granite/Config.in"
        source "package/graphite2/Config.in"
        source "package/gtkmm3/Config.in"
+       source "package/gtksourceview/Config.in"
        source "package/harfbuzz/Config.in"
        source "package/ijs/Config.in"
        source "package/imlib2/Config.in"
diff --git a/package/gtksourceview/Config.in b/package/gtksourceview/Config.in
new file mode 100644 (file)
index 0000000..e87969b
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_GTKSOURCEVIEW
+       bool "gtksourceview"
+       depends on BR2_PACKAGE_LIBGTK3
+       select BR2_PACKAGE_LIBXML2
+       help
+         GtkSourceView is a portable C library that extends the
+         standard GTK+ framework for multiline text editing with
+         support for configurable syntax highlighting, unlimited
+         undo/redo, search and replace, a completion framework,
+         printing and other features typical of a source code editor.
+
+         https://projects.gnome.org/gtksourceview
diff --git a/package/gtksourceview/gtksourceview.hash b/package/gtksourceview/gtksourceview.hash
new file mode 100644 (file)
index 0000000..1fd22af
--- /dev/null
@@ -0,0 +1,2 @@
+# Hash from: http://ftp.gnome.org/pub/gnome/sources/gtksourceview/3.21/gtksourceview-3.21.3.sha256sum:
+sha256 12ea703e1903215629580ddab7751e419bf73a8aacfbbc53c75dc1b9cb0dfba7        gtksourceview-3.21.3.tar.xz
diff --git a/package/gtksourceview/gtksourceview.mk b/package/gtksourceview/gtksourceview.mk
new file mode 100644 (file)
index 0000000..601d6e0
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# gtksourceview
+#
+################################################################################
+
+GTKSOURCEVIEW_VERSION_MAJOR = 3.21
+GTKSOURCEVIEW_VERSION = $(GTKSOURCEVIEW_VERSION_MAJOR).3
+GTKSOURCEVIEW_SOURCE = gtksourceview-$(GTKSOURCEVIEW_VERSION).tar.xz
+GTKSOURCEVIEW_SITE = \
+       http://ftp.gnome.org/pub/gnome/sources/gtksourceview/$(GTKSOURCEVIEW_VERSION_MAJOR)
+GTKSOURCEVIEW_LICENSE = LGPLv2.1+
+GTKSOURCEVIEW_LICENSE_FILES = COPYING
+GTKSOURCEVIEW_INSTALL_STAGING = YES
+GTKSOURCEVIEW_DEPENDENCIES = host-pkgconf libglib2 libxml2 libgtk3
+
+$(eval $(autotools-package))