package/dtc: qemu system build need libfdt
authorGuo Ren <ren_guo@c-sky.com>
Thu, 2 Nov 2017 12:14:33 +0000 (20:14 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 2 Nov 2017 21:13:54 +0000 (22:13 +0100)
The "install-bin" target just installs dtc's programs to host/bin
without libfdt, but building qemu system requires libfdt.

see: https://gitlab.com/c-sky/buildroot/-/jobs/38654503

So we need to install libfdt to satisfy the requirements of qemu.

Signed-off-by: Guo Ren <ren_guo@c-sky.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dtc/dtc.mk

index dd0f30d9aef4090fcfc0973448c78e44ba5109ad..1bcee29bb30aae0de6e8d117be3eba290b77ce0d 100644 (file)
@@ -51,7 +51,7 @@ define HOST_DTC_BUILD_CMDS
 endef
 
 define HOST_DTC_INSTALL_CMDS
-       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR) install-bin
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR) install
 endef
 
 $(eval $(generic-package))