quagga: bump version, fix conflicting options, enhance help
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 30 Sep 2010 19:50:04 +0000 (21:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 Sep 2010 19:50:43 +0000 (21:50 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/quagga/Config.in
package/quagga/quagga-0.99.16-fix-ipctl-forwarding.patch [deleted file]
package/quagga/quagga-fix-ipctl-forwarding.patch [new file with mode: 0644]
package/quagga/quagga.mk

diff --git a/CHANGES b/CHANGES
index 5910bb7b818213c061e45e6cb34329f0f3c9ef40..f5c1616caf0ec217f4d9370e75fcca7e2efae683 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        mdadm, mesa3d, metacity, mtd-utils, mysql_client, nano, nbd,
        ncftp, neon, netperf, netsnmp, ng-spice-rework, ntfsprogs,
        ntp, openntpd, openssh, openvpn, oprofile, pango, patch, pcre,
-       php, pkg-config, prboom, radvd, rdesktop, ruby, qt, samba,
-       sawman, sdl_mixer, sdl_sound, setserial, shared-mime-info,
-       speex, sqlite, squashfs, strace, sylpheed, taglib, tcpdump,
-       thttpd, tiff, tn5250, udev, udpcast, usbmount, usbutils,
-       vsftpd, vtun, which, wpa_supplicant,
+       php, pkg-config, prboom, radvd, rdesktop, ruby, qt, quagga,
+       samba, sawman, sdl_mixer, sdl_sound, setserial,
+       shared-mime-info, speex, sqlite, squashfs, strace, sylpheed,
+       taglib, tcpdump, thttpd, tiff, tn5250, udev, udpcast,
+       usbmount, usbutils, vsftpd, vtun, which, wpa_supplicant,
        xdriver_xf86-input-{acecad,aiptek,evdev,joystick,keyboard},
        xdriver-xf86-input-{mouse,synaptics,vmmouse,void},
        xdriver-xf86-video-{apm,ark,ast,ati,chips,cirrus,dummy,fbdev},
index fb0d590b6e6c93e319df43ddbe55fe8e1c7f2f1e..9ca2f980ec9110eed899a0d3058d5a4247f7046f 100644 (file)
@@ -1,8 +1,8 @@
 config BR2_PACKAGE_QUAGGA
        bool "quagga"
        help
-         routing software suite, providing implementations of
-         OSPFv2, OSPFv3, RIP v1 and v2, RIPng and BGP-4.
+         Routing software suite, providing implementations of
+         OSPFv2, OSPFv3 (IPv6), RIP v1 and v2, RIPng (IPv6) and BGPv4+.
 
          http://www.quagga.net/
 
@@ -13,62 +13,64 @@ config BR2_PACKAGE_QUAGGA_ZEBRA
        help
          Build zebra daemon.
 
-config BR2_PACKAGE_QUAGGA_BGPD
-       bool "bgpd support"
+config BR2_PACKAGE_QUAGGA_TCP_ZEBRA
+       bool "Use TCP sockets between zebra and protocol daemons"
        help
-         Enable bgpd support in quagga.
+         Use a TCP socket to communicate between zebra (supervisor) and
+         the different protocol daemons.
 
-config BR2_PACKAGE_QUAGGA_RIPD
-       bool "ripd support"
+         You'll want this enabled if zebra and the protocol daemon(s) run
+         on different hosts.
+
+config BR2_PACKAGE_QUAGGA_BGPD
+       bool "BPGv4+ protocol"
        help
-         Enable ripd support in quagga.
+         Build bpgd daemon.
 
-config BR2_PACKAGE_QUAGGA_RIPNGD
-       bool "ripngd support"
-       depends on BR2_INET_IPV6
+config BR2_PACKAGE_QUAGGA_BGP_ANNOUNCE
+       bool "BGP route announcement"
+       depends on BR2_PACKAGE_QUAGGA_BGPD
+
+config BR2_PACKAGE_QUAGGA_ISISD
+       bool "IS-IS protocol"
        help
-         Enable ripngd support in quagga.
+         Enable isisd support in quagga.
 
 config BR2_PACKAGE_QUAGGA_OSPFD
-       bool "ospfd support"
+       bool "OSPFv2 protocol"
        help
-         Enable ospfd support in quagga.
+         Build ospfd daemon.
+
+config BR2_PACKAGE_QUAGGA_OPAQUE_LSA
+       bool "OSPF Opaque-LSA with OSPFAPI support (RFC2370)"
+       depends on BR2_PACKAGE_QUAGGA_OSPFD
 
 config BR2_PACKAGE_QUAGGA_OSPF6D
-       bool "ospf6d support"
+       bool "OSPFv3 (IPv6) protocol"
        depends on BR2_INET_IPV6
        help
-         Enable ospf6d support in quagga.
+         Build ospf6d daemon.
 
-config BR2_PACKAGE_QUAGGA_WATCHQUAGGA
-       bool "watchquagga support"
+config BR2_PACKAGE_QUAGGA_RIPD
+       bool "RIPv2/v3 protocol"
        help
-         Enable watchquagga support in quagga.
+         Build ripd daemon.
 
-config BR2_PACKAGE_QUAGGA_ISISD
-       bool "isisd support"
+config BR2_PACKAGE_QUAGGA_RIPNGD
+       bool "RIPng (IPv6) protocol"
+       depends on BR2_INET_IPV6
        help
-         Enable isisd support in quagga.
+         Build ripngd daemon.
 
-config BR2_PACKAGE_QUAGGA_BGP_ANNOUNCE
-       bool "BGP route announcement"
-
-config BR2_PACKAGE_QUAGGA_NETLINK
-       bool "use linux netlink interface"
-       default y
+config BR2_PACKAGE_QUAGGA_WATCHQUAGGA
+       bool "Build watchquagga"
+       help
+         Build and install watchquagga, a zebra/protocol daemon supervisor.
 
 config BR2_PACKAGE_QUAGGA_SNMP
        bool "SNMP support"
-       depends on !BR2_TOOLCHAIN_EXTERNAL
        select BR2_PACKAGE_NETSNMP
-
-comment "quagga snmp support broken with external toolchains"
-       depends on BR2_TOOLCHAIN_EXTERNAL
-
-config BR2_PACKAGE_QUAGGA_TCP_ZEBRA
-       bool "TCP/IP socket connection between zebra and proto daemon"
-
-config BR2_PACKAGE_QUAGGA_OPAGUE_LSA
-       bool "OSPF Opaque-LSA with OSPFAPI support (RFC2370)"
+       help
+         Make quagga information available via SNMP SMUX.
 
 endif
diff --git a/package/quagga/quagga-0.99.16-fix-ipctl-forwarding.patch b/package/quagga/quagga-0.99.16-fix-ipctl-forwarding.patch
deleted file mode 100644 (file)
index e2e3421..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Add definitions for IPCTL_FORWARDING and IP6CTL_FORWARDING.
-
-Inspired from
-http://svn.gnumonks.org/trunk/grouter/build/src/quagga/quagga/quagga-0.99.1-forward_sysctl-2.6.14.patch
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: quagga-0.99.16/zebra/ipforward_sysctl.c
-===================================================================
---- quagga-0.99.16.orig/zebra/ipforward_sysctl.c       2010-06-20 23:40:45.000000000 +0200
-+++ quagga-0.99.16/zebra/ipforward_sysctl.c    2010-06-20 23:41:37.000000000 +0200
-@@ -31,6 +31,15 @@
- #define MIB_SIZ 4
-+/* Fix for recent (2.6.14) kernel headers */
-+#ifndef IPCTL_FORWARDING
-+#define IPCTL_FORWARDING NET_IPV4_FORWARD
-+#endif
-+
-+#ifndef IP6CTL_FORWARDING
-+#define IP6CTL_FORWARDING NET_IPV6_FORWARDING
-+#endif
-+
- extern struct zebra_privs_t zserv_privs;
- /* IPv4 forwarding control MIB. */
diff --git a/package/quagga/quagga-fix-ipctl-forwarding.patch b/package/quagga/quagga-fix-ipctl-forwarding.patch
new file mode 100644 (file)
index 0000000..e2e3421
--- /dev/null
@@ -0,0 +1,27 @@
+Add definitions for IPCTL_FORWARDING and IP6CTL_FORWARDING.
+
+Inspired from
+http://svn.gnumonks.org/trunk/grouter/build/src/quagga/quagga/quagga-0.99.1-forward_sysctl-2.6.14.patch
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: quagga-0.99.16/zebra/ipforward_sysctl.c
+===================================================================
+--- quagga-0.99.16.orig/zebra/ipforward_sysctl.c       2010-06-20 23:40:45.000000000 +0200
++++ quagga-0.99.16/zebra/ipforward_sysctl.c    2010-06-20 23:41:37.000000000 +0200
+@@ -31,6 +31,15 @@
+ #define MIB_SIZ 4
++/* Fix for recent (2.6.14) kernel headers */
++#ifndef IPCTL_FORWARDING
++#define IPCTL_FORWARDING NET_IPV4_FORWARD
++#endif
++
++#ifndef IP6CTL_FORWARDING
++#define IP6CTL_FORWARDING NET_IPV6_FORWARDING
++#endif
++
+ extern struct zebra_privs_t zserv_privs;
+ /* IPv4 forwarding control MIB. */
index 79c0b71cdf1a465c892f43a34fb198dec423d1e0..c1eeee805546b4373dafe7d02c1dd995fd5ae01e 100644 (file)
@@ -3,13 +3,13 @@
 # quagga suite
 #
 #############################################################
-QUAGGA_VERSION:=0.99.16
+QUAGGA_VERSION:=0.99.17
 QUAGGA_SOURCE:=quagga-$(QUAGGA_VERSION).tar.gz
 QUAGGA_SITE:=http://www.quagga.net/download/
 
 QUAGGA_DEPENDENCIES = host-gawk
 QUAGGA_LIBTOOL_PATCH = NO
-QUAGGA_CONF_OPT = --program-transform-name=''
+QUAGGA_CONF_OPT = --program-transform-name='' --enable-netlink
 
 ifeq ($(BR2_PACKAGE_QUAGGA_ZEBRA),y)
 QUAGGA_CONF_OPT+=--enable-zebra
@@ -65,12 +65,6 @@ else
 QUAGGA_CONF_OPT+=--disable-bgp-announce
 endif
 
-ifeq ($(BR2_PACKAGE_QUAGGA_NETLINK),y)
-QUAGGA_CONF_OPT+=--enable-netlink
-else
-QUAGGA_CONF_OPT+=--disable-netlink
-endif
-
 ifeq ($(BR2_PACKAGE_QUAGGA_SNMP),y)
 QUAGGA_CONF_OPT+=--enable-snmp
 QUAGGA_DEPENDENCIES+=netsnmp
@@ -84,7 +78,7 @@ else
 QUAGGA_CONF_OPT+=--disable-tcp-zebra
 endif
 
-ifeq ($(BR2_PACKAGE_QUAGGA_OPAGUE_LSA),y)
+ifeq ($(BR2_PACKAGE_QUAGGA_OPAQUE_LSA),y)
 QUAGGA_CONF_OPT+=--enable-opaque-lsa
 else
 QUAGGA_CONF_OPT+=--disable-opaque-lsa