rfkill: new package
authorVolkov Viacheslav <sv99@inbox.ru>
Wed, 28 Oct 2015 08:02:43 +0000 (11:02 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Dec 2015 21:58:39 +0000 (22:58 +0100)
[Thomas: use "br" as the version suffix instead of "-br" so that the
final version string is "0.5-br" and not "0.5--br".]

Signed-off-by: Viacheslav Volkov <sv99@inbox.ru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/rfkill/Config.in [new file with mode: 0644]
package/rfkill/rfkill.hash [new file with mode: 0644]
package/rfkill/rfkill.mk [new file with mode: 0644]

index 4a1d7067a05ac7d1ad3091d87257e3473c5395a6..4292188e79c16f84ee711154ca85e8ab7534f5fe 100644 (file)
@@ -419,6 +419,7 @@ endif
        source "package/pps-tools/Config.in"
        source "package/pulseview/Config.in"
        source "package/read-edid/Config.in"
+       source "package/rfkill/Config.in"
        source "package/rng-tools/Config.in"
        source "package/rpi-userland/Config.in"
        source "package/rtl8188eu/Config.in"
diff --git a/package/rfkill/Config.in b/package/rfkill/Config.in
new file mode 100644 (file)
index 0000000..0d07913
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RFKILL
+       bool "rfkill"
+       help
+         rfkill is a small userspace tool to query the state of the
+         rfkill switches.
+
+         https://wireless.wiki.kernel.org/en/users/documentation/rfkill
diff --git a/package/rfkill/rfkill.hash b/package/rfkill/rfkill.hash
new file mode 100644 (file)
index 0000000..21be0a2
--- /dev/null
@@ -0,0 +1,2 @@
+# From: https://www.kernel.org/pub/software/network/rfkill/sha256sums.asc
+sha256 e0ae3004215e39a6c5c36e0726558740728d16f67ebdb8bea621250f6091d86a  rfkill-0.5.tar.xz
diff --git a/package/rfkill/rfkill.mk b/package/rfkill/rfkill.mk
new file mode 100644 (file)
index 0000000..2f9fe9f
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# rfkill
+#
+################################################################################
+
+RFKILL_VERSION = 0.5
+RFKILL_SOURCE = rfkill-$(RFKILL_VERSION).tar.xz
+RFKILL_SITE = https://www.kernel.org/pub/software/network/rfkill
+RFKILL_LICENSE = ISC
+RFKILL_LICENSE_FILES = COPYING
+
+define RFKILL_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               VERSION_SUFFIX="br"
+endef
+
+define RFKILL_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))