systemd: add optional dependency on pcre2
authorJérémy Rosen <jeremy.rosen@smile.fr>
Fri, 29 Jun 2018 22:25:51 +0000 (00:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Jul 2018 12:19:44 +0000 (14:19 +0200)
systemd can use libpcre2 when available, so this commit adds the
detection of this library.

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 16c9d9f290792dc110527dffe919d7a7816cbd49..0d5e348594dbc05e70520a04c79d718bc367c1f5 100644 (file)
@@ -144,6 +144,13 @@ else
 SYSTEMD_CONF_OPTS += -Dgcrypt=false
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE2),y)
+SYSTEMD_DEPENDENCIES += pcre2
+SYSTEMD_CONF_OPTS += -Dpcre2=true
+else
+SYSTEMD_CONF_OPTS += -Dpcre2=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)
 SYSTEMD_DEPENDENCIES += libmicrohttpd
 SYSTEMD_CONF_OPTS += -Dmicrohttpd=true