package/libselinux: install Python modules to target
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 22 Oct 2019 08:49:23 +0000 (10:49 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 24 Oct 2019 09:06:01 +0000 (11:06 +0200)
While LIBSELINUX_INSTALL_STAGING_CMDS uses
$(LIBSELINUX_MAKE_INSTALL_TARGETS), LIBSELINUX_INSTALL_TARGET_CMDS
does not use it. Due to this, the Python module is only installed to
$(STAGING_DIR) and not to $(TARGET_DIR).

Fix this by using $(LIBSELINUX_MAKE_INSTALL_TARGETS) in
LIBSELINUX_INSTALL_TARGET_CMDS.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: James Hilliard <james.hilliard1@gmail.com>
Cc: Matt Weber <matthew.weber@rockwellcollins.com>
Cc: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libselinux/libselinux.mk

index c707c8a25e388c5c0f384f727324728e3c4f1327..c68721e3a7aabc7dd7862f4e99d97f1d0bb618ea 100644 (file)
@@ -72,7 +72,8 @@ endef
 
 define LIBSELINUX_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
-               $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
+               $(LIBSELINUX_MAKE_OPTS) DESTDIR=$(TARGET_DIR) \
+               $(LIBSELINUX_MAKE_INSTALL_TARGETS)
        # Create the selinuxfs mount point
        if [ ! -d "$(TARGET_DIR)/selinux" ]; then mkdir $(TARGET_DIR)/selinux; fi
        if ! grep -q "selinuxfs" $(TARGET_DIR)/etc/fstab; then \