qjson: allow building with Qt5
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Nov 2014 22:15:10 +0000 (23:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Nov 2014 22:06:12 +0000 (23:06 +0100)
Since commit 18714011b231fc326c96782134fbea778ab6a94d ("qjson: bump
version"), qjson can be built either against Qt4 or Qt5. This commit
therefore allows this package to be selected when Qt5 is enabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qjson/Config.in
package/qjson/qjson.mk

index 2dc2cc405e9f76016f54d90d8ff03a4515a605ad..0f0cc0983e7eadfdcc6b616c41f6fda1d7f4df91 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_QJSON
        bool "qjson"
-       depends on BR2_PACKAGE_QT
+       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
        help
          QJson is a Qt-based library that maps JSON data to
          QVariant objects and vice versa.
index 17f2d00317db7a268b5ded6929af018586dba998..6a1661733dcaf5db163a0ddf6fb7a4af8bb01ddb 100644 (file)
@@ -7,7 +7,9 @@
 QJSON_VERSION = ba273682a9d33a7b3090e74f4742b5f3bf6c9b02
 QJSON_SITE = $(call github,flavio,qjson,$(QJSON_VERSION))
 QJSON_INSTALL_STAGING = YES
-QJSON_DEPENDENCIES = qt
+QJSON_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_QT),qt) \
+       $(if $(BR2_PACKAGE_QT5),qt5base)
 QJSON_LICENSE = LGPLv2.1
 QJSON_LICENSE_FILES = COPYING.lib