package/rtl_433: force Release build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 2 Aug 2021 09:47:04 +0000 (11:47 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Aug 2021 20:32:45 +0000 (22:32 +0200)
Force Release build to avoid the following build failure which is raised
since the addition of the package in commit
4634e84978a3e64e9050021d209a41cd88a1ad16:

/tmp/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: cannot find -lasan
/tmp/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: cannot find -lubsan

Fixes:
 - http://autobuild.buildroot.org/results/83274082879f9599bc106e12a253f4b9229ea00b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/rtl_433/rtl_433.mk

index e6d28721fa4e314f068c1b2e0325cfc9c8d71d76..df00c095181482d226748d956a3f802303101016 100644 (file)
@@ -9,7 +9,9 @@ RTL_433_SITE = $(call github,merbanan,rtl_433,$(RTL_433_VERSION))
 RTL_433_LICENSE = GPL-2.0+
 RTL_433_LICENSE_FILES = COPYING
 
+# Force Release build to remove ASAN.
 RTL_433_CONF_OPTS = \
+       -DCMAKE_BUILD_TYPE=Release \
        -DBUILD_DOCUMENTATION=OFF \
        -DBUILD_TESTING=OFF \
        -DBUILD_TESTING_ANALYZER=OFF \