libnss: add build workaround for older gcc versions
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 6 Jan 2016 14:18:54 +0000 (11:18 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 22 Jan 2016 09:10:34 +0000 (10:10 +0100)
nss uses some #pragma directives that require newish (>= 4.6) versions
of gcc, so disable Werror when building with older versions to avoid the
build from breaking unfairly.
However make this a gcc >= 4.8 conditional since the kludge is called so
(NSS_NO_GCC48) and other bits might depend upon it.

Upstream bug https://bugzilla.mozilla.org/show_bug.cgi?id=1226179

Fixes:
http://autobuild.buildroot.net/results/ebd/ebd0647eb1eef41a7fb6e5f5bab18d4d12168661/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libnss/libnss.mk

index 10879e219d172060addca3c206bd70f18dd8a3b2..6fdb77cd14812f96d7bb56a0f55d72145f17c887 100644 (file)
@@ -30,6 +30,12 @@ LIBNSS_BUILD_VARS = \
        OS_RELEASE="2.6" \
        OS_TEST="$(ARCH)"
 
+# #pragma usage needs gcc >= 4.8
+# See https://bugzilla.mozilla.org/show_bug.cgi?id=1226179
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_8),)
+LIBNSS_BUILD_VARS += NSS_ENABLE_WERROR=0
+endif
+
 ifeq ($(BR2_ARCH_IS_64),y)
 # MIPS64 n32 is treated as a 32-bit architecture by libnss.
 # See: https://bugzilla.mozilla.org/show_bug.cgi?id=1010730