Support KERNEL_ARCH for AArch64
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Oct 2012 16:40:35 +0000 (17:40 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 2 Nov 2012 20:08:50 +0000 (21:08 +0100)
The architecture tuple is 'aarch64', but the kernel people decided to
call it 'arm64', so we have to do some mungling to get the kernel
architecture name from the Buildroot architecture name.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 0128839e296ddb3980fe09d3ef75fe88d00c58ca..dff6aeb2f38b5f6ece8265f6bf04f4fb54952121 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -235,6 +235,7 @@ ARCH:=$(call qstrip,$(BR2_ARCH))
 KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
        -e s/i.86/i386/ -e s/sun4u/sparc64/ \
        -e s/arm.*/arm/ -e s/sa110/arm/ \
+       -e s/aarch64/arm64/ \
        -e s/bfin/blackfin/ \
        -e s/parisc64/parisc/ \
        -e s/powerpc64/powerpc/ \