setools: change sepol library directory
authorAdam Duskett <aduskett@gmail.com>
Thu, 19 Oct 2017 21:46:03 +0000 (17:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 08:00:52 +0000 (10:00 +0200)
setools currently points the libsepol library directory to
$(STAGING_DIR)/lib/ when it should be $(STAGING_DIR)/usr/lib

Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/setools/setools.mk

index 80d58235d3fc633177c54d8cfce00c7e3d25f1f7..8b93ccf45e12a163d80187c7f4f6409b2bd7f31f 100644 (file)
@@ -24,7 +24,7 @@ endif
 define SETOOLS_FIX_SETUP
        # By default, setup.py will look for libsepol.a in the host machines
        # /usr/lib directory. This needs to be changed to the staging directory.
-       $(SED) "s@base_lib_dirs =.*@base_lib_dirs = ['$(STAGING_DIR)/lib']@g" \
+       $(SED) "s@base_lib_dirs =.*@base_lib_dirs = ['$(STAGING_DIR)/usr/lib']@g" \
                $(@D)/setup.py
 endef
 SETOOLS_POST_PATCH_HOOKS += SETOOLS_FIX_SETUP