qt: fix directfb dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jul 2010 21:54:21 +0000 (23:54 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jul 2010 21:55:12 +0000 (23:55 +0200)
Closes #2221

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/qt/qt.mk

diff --git a/CHANGES b/CHANGES
index 35e7fde1d6a21f79e513fae9b37d7bb91b0156fc..e1f8a0e0be467db59ca77487cd216c98bc8db322 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -59,6 +59,7 @@
        #2155: Compression lzo don't set for ubifs
        #2166: [SECURITY] Update libpng to 1.2.44
        #2167: Bump busybox to 1.17.0, convert to gentargets, drop 1.12, ...
+       #2221: Qt does not compile (dependencies not taken into account?)
 
 2010.05, Released May 30th, 2010:
 
index b4b6b29951472d28b95b2f7bc97473e12182dd46..dd43ae02b4cede7bdeea885191295e8d4a971850 100644 (file)
@@ -115,6 +115,7 @@ QT_CONFIGURE += -no-gfx-multiscreen
 endif
 ifeq ($(BR2_PACKAGE_QT_GFX_DIRECTFB),y)
 QT_CONFIGURE += -qt-gfx-directfb
+QT_DEP_LIBS+=directfb
 else
 QT_CONFIGURE += -no-gfx-directfb
 endif