libgudev: New package
authorNathaniel Roach <nroach44@gmail.com>
Mon, 24 Aug 2015 15:44:14 +0000 (23:44 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 25 Aug 2015 14:35:15 +0000 (16:35 +0200)
As libgudev recently was split from the main systemd/udev source, this
library is now required to build certain packages.

This library is only relevant to systemd, as the code it contains is
still contained in eudev.

[Thomas:
 - don't show the dependency comment when systemd is not available,
   since libgudev is anyway useless when you're not using systemd.
 - fix the license, it's LGPLv2.1+ and not GPLv2+
 - remove useless empty lines in the .mk file.]

Signed-off-by: Nathaniel Roach <nroach44@gmail.com>
Tested-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libgudev/Config.in [new file with mode: 0644]
package/libgudev/libgudev.mk [new file with mode: 0644]
package/systemd/Config.in

index 35fe0267b0eea4f86cfaabf655c6bec3e539fb25..eb28ccbb143c43e6f594ece4fb462a7d427e0923 100644 (file)
@@ -853,6 +853,7 @@ menu "Hardware handling"
        source "package/libfreefare/Config.in"
        source "package/libftdi/Config.in"
        source "package/libftdi1/Config.in"
+       source "package/libgudev/Config.in"
        source "package/libhid/Config.in"
        source "package/libiio/Config.in"
        source "package/libinput/Config.in"
diff --git a/package/libgudev/Config.in b/package/libgudev/Config.in
new file mode 100644 (file)
index 0000000..9b64ffc
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_LIBGUDEV
+       bool "libgudev"
+       depends on BR2_INIT_SYSTEMD
+       depends on BR2_USE_WCHAR # gettext
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         This library provides GObject bindings for libudev.  It was
+         originally part of udev-extras, then udev, then systemd.
+         It's now a project on its own. Required for building some
+         programs that use udev, when using systemd.
+
+         When systemd is not used, libgudev is directly provided by
+         eudev.
+
+         https://wiki.gnome.org/Projects/libgudev
+
+comment "libgudev needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on BR2_INIT_SYSTEMD
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libgudev/libgudev.mk b/package/libgudev/libgudev.mk
new file mode 100644 (file)
index 0000000..dce9cd8
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libgudev
+#
+################################################################################
+
+LIBGUDEV_VERSION = 230
+LIBGUDEV_SOURCE = libgudev-$(LIBGUDEV_VERSION).tar.xz
+LIBGUDEV_SITE = http://ftp.gnome.org/pub/GNOME/sources/libgudev/$(LIBGUDEV_VERSION)
+LIBGUDEV_INSTALL_STAGING = YES
+LIBGUDEV_DEPENDENCIES = host-pkgconf udev libglib2
+LIBGUDEV_LICENSE = LGPLv2.1+
+LIBGUDEV_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))
index 510baddae73fd8769ce06d313ef7849836dd6e37..f7fc3bbfde7db6a2a8269865de0540854031c86d 100644 (file)
@@ -55,7 +55,6 @@ config BR2_PACKAGE_SYSTEMD
 
          The selection of other packages will enable some features:
 
-         - libglib2 package will add support for gudev.
          - acl package will add support for multi-seat.
 
          http://freedesktop.org/wiki/Software/systemd