tcpreplay: bump to version 4.0.3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Mar 2014 20:26:34 +0000 (17:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Mar 2014 22:05:08 +0000 (23:05 +0100)
Patch removed, already upstream.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tcpreplay/tcpreplay-0001-Fix-build-errors-when-ENABLE_VERBOSE-is-not-set.patch [deleted file]
package/tcpreplay/tcpreplay.mk

diff --git a/package/tcpreplay/tcpreplay-0001-Fix-build-errors-when-ENABLE_VERBOSE-is-not-set.patch b/package/tcpreplay/tcpreplay-0001-Fix-build-errors-when-ENABLE_VERBOSE-is-not-set.patch
deleted file mode 100644 (file)
index cbc829d..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From 12d0d0876a9a9bf2818ba24ecb5646952b958c39 Mon Sep 17 00:00:00 2001
-From: Chris Packham <judge.packham@gmail.com>
-Date: Wed, 22 Jan 2014 20:37:04 +1300
-Subject: [PATCH] Fix build errors when ENABLE_VERBOSE is not set
-
-Upstream: https://github.com/cpackham/tcpreplay/commit/12d0d0876a9a9
-Fixes #59
-
-When ENABLE_VERBOSE is not set some additional calls to tcpreplay_seterr
-are made. When conforming to C99 variadic macros at least one argument is
-required after the format string[1]. To avoid this problem update the
-calls to tcpreplay_seterr to use a "%s" format string.
-
-[1] - http://gcc.gnu.org/onlinedocs/cpp/Variadic-Macros.html
-
-Signed-off-by: Chris Packham <judge.packham@gmail.com>
----
- src/tcpreplay_api.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/tcpreplay_api.c b/src/tcpreplay_api.c
-index 6b81bcc..de67080 100644
---- a/src/tcpreplay_api.c
-+++ b/src/tcpreplay_api.c
-@@ -690,7 +690,7 @@ tcpreplay_set_verbose(tcpreplay_t *ctx, bool value)
-     ctx->options->verbose = value;
-     return 0;
- #else
--    tcpreplay_seterr(ctx, "verbose mode not supported");
-+    tcpreplay_seterr(ctx, "%s", "verbose mode not supported");
-     return -1;
- #endif
- }
-@@ -710,7 +710,7 @@ tcpreplay_set_tcpdump_args(tcpreplay_t *ctx, char *value)
-     ctx->options->tcpdump_args = safe_strdup(value);
-     return 0;
- #else
--    tcpreplay_seterr(ctx, "verbose mode not supported");
-+    tcpreplay_seterr(ctx, "%s", "verbose mode not supported");
-     return -1;
- #endif
- }
-@@ -731,7 +731,7 @@ tcpreplay_set_tcpdump(tcpreplay_t *ctx, tcpdump_t *value)
-     ctx->options->tcpdump = value;
-     return 0;
- #else
--    tcpreplay_seterr(ctx, "verbose mode not supported");
-+    tcpreplay_seterr(ctx, "%s", "verbose mode not supported");
-     return -1;
- #endif
- }
--- 
-1.8.5.2
-
index fdb42a50bed13330d2acfd733a7300d55b90760a..e1ff1f506f956d0f3ca33ea7095987be757f2944 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TCPREPLAY_VERSION = 4.0.2
+TCPREPLAY_VERSION = 4.0.3
 TCPREPLAY_SITE = http://downloads.sourceforge.net/project/tcpreplay/tcpreplay/$(TCPREPLAY_VERSION)
 TCPREPLAY_LICENSE = GPLv3
 TCPREPLAY_LICENSE_FILES = docs/LICENSE