QEMU: Enable package for MIPS targets
authorMarkos Chandras <markos.chandras@imgtec.com>
Thu, 23 Apr 2015 09:50:57 +0000 (10:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 08:17:01 +0000 (10:17 +0200)
Allow QEMU to be installed on MIPS targets. Also introduce a new
symbol (BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET) to hold the
architectures than can build and use QEMU on the target.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qemu/Config.in
package/qemu/qemu.mk

index fff786d3f11f930a7fd53bd47b852ef8ccebd72e..25936e23337d5df2c74b988f4c0cdc68faf4f519 100644 (file)
@@ -1,11 +1,16 @@
+config BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
+       bool
+       # Only tested on these architectures
+       default y if BR2_i386 || BR2_mips || BR2_mipsel || BR2_x86_64
+
 comment "QEMU requires a toolchain with wchar, threads"
-       depends on BR2_i386 || BR2_x86_64
+       depends on BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
        depends on BR2_USE_MMU
        depends on !(BR2_TOOLCHAIN_HAS_THREADS && BR2_USE_WCHAR)
 
 config BR2_PACKAGE_QEMU
        bool "QEMU"
-       depends on BR2_i386 || BR2_x86_64
+       depends on BR2_PACKAGE_QEMU_ARCH_SUPPORTS_TARGET
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_WCHAR # gettext
        depends on BR2_USE_MMU # fork()
index b73127b24748786d1daa6a7a45a2124010730ba7..decfc259d2e3631f52e5e7c0ddb691445fd13194 100644 (file)
@@ -32,8 +32,8 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-python host-zlib host-libglib2 host-p
 #       microblaze      microblaze
 #       mips            mips
 #       mipsel          mipsel
-#       mips64          ?
-#       mips64el        ?
+#       mips64          mips64
+#       mips64el        mips64el
 #       powerpc         ppc
 #       sh2a            not supported
 #       sh4             sh4