DNS resolv problem with glibc
authorAnders Darander <anders.darander@gmail.com>
Tue, 15 Sep 2009 06:13:10 +0000 (08:13 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 15 Sep 2009 06:50:12 +0000 (08:50 +0200)
Fix problem with dns resolv, by copying the libnss_dns.so to the rootfs.

Using glibc from external toolchain, name resolving does not work,
unless libnss_dns.so is available on the target.

Signed-off-by: Anders Darander <ad@datarespons.se>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/external-toolchain/ext-tool.mk

index 568ac3a35bc9be16f9a72dbcd3fe2e0e0bc141d0..1f5aa19322d0a90db916bfb859353a8a389cfa3e 100644 (file)
@@ -198,7 +198,7 @@ EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthr
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
 EXTERNAL_LIBS+=ld-uClibc.so
 else
-EXTERNAL_LIBS+=ld-linux.so libnss_files.so
+EXTERNAL_LIBS+=ld-linux.so libnss_files.so libnss_dns.so
 endif
 
 ifeq ($(BR2_INSTALL_LIBSTDCPP),y)