Build proftpd with IPv6 support only if the toolchain was configured as such.
author"Steven J. Hill" <sjhill@realitydiluted.com>
Tue, 17 Jul 2007 00:22:39 +0000 (00:22 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Tue, 17 Jul 2007 00:22:39 +0000 (00:22 -0000)
package/proftpd/proftpd.mk

index 2130b1eee4157cf98f31a9a000afb50dc17a4f3f..a2e38bdc464ff61c55c68ce8abf145ca9bf25461 100644 (file)
@@ -11,6 +11,10 @@ PROFTPD_CAT:=bzcat
 PROFTPD_BINARY:=proftpd
 PROFTPD_TARGET_BINARY:=usr/sbin/proftpd
 
+ifeq ($(BR2_INET_IPV6),y)
+ENABLE_IPV6:=--enable-ipv6
+endif
+
 $(DL_DIR)/$(PROFTPD_SOURCE):
         $(WGET) -P $(DL_DIR) $(PROFTPD_SITE)/$(PROFTPD_SOURCE)
 
@@ -40,6 +44,7 @@ $(PROFTPD_DIR)/.configured: $(PROFTPD_DIR)/.unpacked
                --disable-dso \
                --enable-shadow \
                $(DISABLE_LARGEFILE) \
+               $(ENABLE_IPV6) \
                --with-gnu-ld \
        );
        touch $(PROFTPD_DIR)/.configured