python-simplejson: new package
authorLudovic Desroches <ludovic.desroches@atmel.com>
Wed, 11 Dec 2013 20:27:04 +0000 (21:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:35 +0000 (13:41 +0100)
[Thomas: convert to the Python package infrastructure, drop the
setuptools dependency since the package uses distutils.]

Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-simplejson/Config.in [new file with mode: 0644]
package/python-simplejson/python-simplejson.mk [new file with mode: 0644]

index e8ecb6acdb0c980726ec0b892ba07779d72d9e0d..097ae79a262542371846c313b4a25c770e19e271 100644 (file)
@@ -406,6 +406,7 @@ source "package/python-pyusb/Config.in"
 source "package/python-pyzmq/Config.in"
 source "package/python-serial/Config.in"
 source "package/python-setuptools/Config.in"
+source "package/python-simplejson/Config.in"
 source "package/python-thrift/Config.in"
 source "package/python-versiontools/Config.in"
 endmenu
diff --git a/package/python-simplejson/Config.in b/package/python-simplejson/Config.in
new file mode 100644 (file)
index 0000000..be0ee8f
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_SIMPLEJSON
+       bool "python-simplejson"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         Simple, fast, extensible JSON encoder/decoder for Python
+
+         https://pypi.python.org/pypi/simplejson/
diff --git a/package/python-simplejson/python-simplejson.mk b/package/python-simplejson/python-simplejson.mk
new file mode 100644 (file)
index 0000000..eb6287a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-simplejson
+#
+################################################################################
+
+PYTHON_SIMPLEJSON_VERSION = 3.3.1
+PYTHON_SIMPLEJSON_SOURCE = simplejson-$(PYTHON_SIMPLEJSON_VERSION).tar.gz
+PYTHON_SIMPLEJSON_SITE = http://pypi.python.org/packages/source/s/simplejson/
+PYTHON_SIMPLEJSON_LICENSE = MIT
+PYTHON_SIMPLEJSON_LICENSE_FILES = LICENSE.txt
+PYTHON_SIMPLEJSON_SETUP_TYPE = distutils
+
+$(eval $(python-package))