boot/optee-os: install trusted shared libraries
authorEtienne Carriere <etienne.carriere@linaro.org>
Tue, 14 May 2019 08:53:14 +0000 (10:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 May 2019 15:46:44 +0000 (17:46 +0200)
Install generated trusted shared libraries in the target file
system next to the trusted applications.

Signed-off-by: Etienne Carriere <etienne.carriere@linaro.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/optee-os/Config.in
boot/optee-os/optee-os.mk

index a1f1b910ac8137ca01cc44bf3d25c6b8f237ec73..4cb05798e5505661248db1ead98f5539db730a6b 100644 (file)
@@ -70,16 +70,16 @@ config BR2_TARGET_OPTEE_OS_SDK
          installed in the staging directory /lib/optee.
 
 config BR2_TARGET_OPTEE_OS_SERVICES
-       bool "Build service TAs"
+       bool "Build service TAs and libs"
        default y
        select BR2_TARGET_OPTEE_OS_CORE
        help
-         This option installs the service trusted applications built
-         from OP-TEE OS source tree. These are installed in the target
-         /lib/optee_armtz directory as other trusted applications.
-         At runtime OP-TEE OS can load trusted applications from this
-         non-secure filesystem/directory into the secure world for
-         execution.
+         This option installs the service trusted applications and
+         trusted shared libraries built from OP-TEE OS source tree.
+         These are installed in target /lib/optee_armtz directory
+         as other trusted applications. At runtime OP-TEE OS can
+         load these from this non-secure filesystem/directory into
+         the secure world for execution.
 
 config BR2_TARGET_OPTEE_OS_PLATFORM
        string "Target platform (mandatory)"
index b22f560ba7fd2185f789f128c38300cda79d6810..bd415512c7410aae4f21ae19371feb08673ad020 100644 (file)
@@ -79,6 +79,9 @@ define OPTEE_OS_INSTALL_TARGET_CMDS
        $(if $(wildcard $(@D)/$(OPTEE_OS_BUILDDIR_OUT)/ta/*/*.ta),
                $(INSTALL) -D -m 444 -t $(TARGET_DIR)/lib/optee_armtz \
                        $(@D)/$(OPTEE_OS_BUILDDIR_OUT)/ta/*/*.ta)
+       $(if $(wildcard $(@D)/$(OPTEE_OS_LOCAL_SDK)/lib/*.ta),
+               $(INSTALL) -D -m 444 -t $(TARGET_DIR)/lib/optee_armtz \
+                       $(@D)/$(OPTEE_OS_LOCAL_SDK)/lib/*.ta)
 endef
 endif # BR2_TARGET_OPTEE_OS_SERVICES