make help: sort defconfigs for make 3.82
authorDanomi Mocelopolis <d_mo1234@yahoo.com>
Sun, 17 Jul 2011 20:17:08 +0000 (22:17 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Jul 2011 20:19:19 +0000 (22:19 +0200)
Closes #3985

The wildcard function in make 3.82 no longer sorts the output, so
add an explicit sort so the defconfigs are listed in a sensible order.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
Makefile

diff --git a/CHANGES b/CHANGES
index 06a7e53cd982cca040ffd2ec328253e313fe39a9..a6016cc61a1db1a7e5907688297eaec7e82d3dbe 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -31,6 +31,7 @@
        #3595: patch to add libroxml
        #3565: libnss: Add new package
        #3907: 2011.05 - Qt 4.7.3 not building on ARM
+       #3985: "help" target's defconfig list needs sort
 
 2011.05, Released May 27th, 2011:
 
index ffe634391fe61cf2f34a115dd89a7d8088931c0e..02a16599911cdc676b6d988a09ad26db4fb107d2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -668,7 +668,7 @@ endif
        @echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'
        @echo '  make O=dir             - Locate all output files in "dir", including .config'
        @echo
-       @$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
+       @$(foreach b, $(sort $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig))), \
          printf "  %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
        @echo
        @echo 'See docs/README and docs/buildroot.html for further details'