package/wpewebkit: add optional systemd dependency
authorAdrian Perez de Castro <aperez@igalia.com>
Tue, 10 Nov 2020 09:02:04 +0000 (11:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2020 22:19:19 +0000 (23:19 +0100)
WPE WebKit 2.30.0 added an USE_SYSTEMD buil option, which needs to
be set to avoid CMake from trying to use systemd unconditionally.

Based on a similar patch for package/webkitgtk by Peter Seiderer.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wpewebkit/wpewebkit.mk

index 6233505ca7f522ebcd219aacc16dc32e6a9cff0a..6f83775e962f4b9317333d40c5cc96ea5208bca4 100644 (file)
@@ -63,6 +63,13 @@ else
 WPEWEBKIT_CONF_OPTS += -DUSE_WOFF2=OFF
 endif
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+WPEWEBKIT_CONF_OPTS += -DUSE_SYSTEMD=ON
+WPEWEBKIT_DEPENDENCIES += systemd
+else
+WPEWEBKIT_CONF_OPTS += -DUSE_SYSTEMD=OFF
+endif
+
 # JIT is not supported for MIPS r6, but the WebKit build system does not
 # have a check for these processors. The same goes for ARMv5 and ARMv6.
 # Disable JIT forcibly here and use the CLoop interpreter instead.