collectd: use $(TARGET_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Mon, 17 Oct 2016 16:06:57 +0000 (13:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Oct 2016 13:19:24 +0000 (15:19 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/collectd/collectd.mk

index b9422f3a9cdb3d389991c961680db0dfbeb24a33..4846ee4cb242e079df1b2c6b0c0b656d479ac520 100644 (file)
@@ -180,7 +180,7 @@ endef
 COLLECTD_POST_PATCH_HOOKS += COLLECTD_DROP_WERROR
 
 define COLLECTD_INSTALL_TARGET_CMDS
-       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+       $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
        rm -f $(TARGET_DIR)/usr/bin/collectd-nagios
        rm -f $(TARGET_DIR)/usr/share/collectd/postgresql_default.conf
 endef