system: set root password only for default skeleton
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 5 Jan 2013 04:52:02 +0000 (04:52 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 Jan 2013 20:46:47 +0000 (21:46 +0100)
In case one is using a custom skeleton, the root pasword might already be
set in this case, and should not be overriden.

Just ask for (and set) the root password only for the default skeleton.

Reported-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
system/Config.in
system/system.mk

index 5b66ac0fb0cdc0fd1ba2b66fbdd3e685641c98bb..19bdd2d7461fb38f1b619be4064e3d1ad3ef2c59 100644 (file)
@@ -12,27 +12,6 @@ config BR2_TARGET_GENERIC_ISSUE
        help
          Select system banner (/etc/issue) to be displayed at login.
 
-config BR2_TARGET_GENERIC_ROOT_PASSWD
-       string "Root password"
-       default ""
-       help
-         Set the initial root password (in clear). It will be md5-encrypted.
-         
-         If set to empty (the default), then no root password will be set,
-         and root will need no password to log in.
-         
-         WARNING! WARNING!
-         Although pretty strong, MD5 is now an old hash function, and
-         suffers from some weaknesses, which makes it susceptible to attacks.
-         It is showing its age, so this root password should not be trusted
-         to properly secure any product that can be shipped to the wide,
-         hostile world.
-         
-         WARNING! WARNING!
-         The password appears in clear in the .config file, and may appear
-         in the build log! Avoid using a valuable password if either the
-         .config file or the build log may be distributed!
-
 choice
        prompt "/dev management"
        default BR2_ROOTFS_DEVICE_CREATION_STATIC
@@ -140,6 +119,27 @@ endif
 
 if BR2_ROOTFS_SKELETON_DEFAULT
 
+config BR2_TARGET_GENERIC_ROOT_PASSWD
+       string "Root password"
+       default ""
+       help
+         Set the initial root password (in clear). It will be md5-encrypted.
+         
+         If set to empty (the default), then no root password will be set,
+         and root will need no password to log in.
+         
+         WARNING! WARNING!
+         Although pretty strong, MD5 is now an old hash function, and
+         suffers from some weaknesses, which makes it susceptible to attacks.
+         It is showing its age, so this root password should not be trusted
+         to properly secure any product that can be shipped to the wide,
+         hostile world.
+         
+         WARNING! WARNING!
+         The password appears in clear in the .config file, and may appear
+         in the build log! Avoid using a valuable password if either the
+         .config file or the build log may be distributed!
+
 config BR2_TARGET_GENERIC_GETTY_PORT
        string "Port to run a getty (login prompt) on"
        default "ttyS0"
index 3c4d06e69ca39c3cda8dc2ad78424c4b3f74ba07..651f7df0f6b01b7b76aed22c4703dff35424906c 100644 (file)
@@ -47,7 +47,9 @@ ifneq ($(TARGET_GENERIC_ISSUE),)
 TARGETS += target-generic-issue
 endif
 
+ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
 TARGETS += target-root-passwd
+endif
 
 ifneq ($(TARGET_GENERIC_GETTY),)
 ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)