pppd: fix plugin search path
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 11 Jun 2012 07:20:39 +0000 (07:20 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jun 2012 19:32:31 +0000 (21:32 +0200)
Fix the plugin search path by passing a --prefix to configure.
DESTDIR is used in the source code for the search path of plugins
(DESTDIR/lib/pppd/VERSION).
Since DESTDIR defaults to /usr/local we get the search path wrong so the
'plugin' directive requires a full pathspec to the plugin rather than
the .so name, which isn't nice or portable.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pppd/pppd.mk

index 2137f6a4e1802d7ee193b006e4eac24c45cad081..a62f495c107186d3ac07f52324fdce5ef698d7c2 100644 (file)
@@ -26,7 +26,7 @@ endif
 define PPPD_CONFIGURE_CMDS
        $(SED) 's/FILTER=y/#FILTER=y/' $(PPPD_DIR)/pppd/Makefile.linux
        $(SED) 's/ifneq ($$(wildcard \/usr\/include\/pcap-bpf.h),)/ifdef FILTER/' $(PPPD_DIR)/*/Makefile.linux
-       ( cd $(@D); ./configure )
+       ( cd $(@D); ./configure --prefix=/usr )
 endef
 
 define PPPD_BUILD_CMDS