package/libtirpc: install rpc.h
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 16 Jul 2021 22:09:41 +0000 (00:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Jul 2021 08:01:23 +0000 (10:01 +0200)
Install rpc.h to avoid the following build failure with host-nfs-utils
in version 2.5.4 raised since commit
0ce30de72fb303768c5865949b8ce9260d0c43f5:

checking rpc/rpc.h usability... no
checking rpc/rpc.h presence... no
checking for rpc/rpc.h... no
configure: error: Header file rpc/rpc.h not found - maybe try building with --enable-tirpc

This build failure is raised by
http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=be7365239abf8556773b063730621967b9971708

Fixes:
 - http://autobuild.buildroot.org/results/a5eaf19f58729c4c00a2131b6a0c378c0fc0effb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libtirpc/libtirpc.mk

index 2678c144e9e523472f39ba8396a14c27dc698487..8cdc453cd4a0867f81550d543d5fa4d62bfd8dac 100644 (file)
@@ -21,6 +21,7 @@ LIBTIRPC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DGQ"
 LIBTIRPC_CONF_OPTS = --disable-gssapi
 
 define HOST_LIBTIRPC_INSTALL_CMDS
+       $(INSTALL) -D -m 0644 $(@D)/tirpc/rpc/rpc.h $(HOST_DIR)/include/rpc/rpc.h
        $(INSTALL) -D -m 0644 $(@D)/tirpc/rpc/types.h $(HOST_DIR)/include/rpc/types.h
        $(INSTALL) -D -m 0644 $(@D)/tirpc/netconfig.h $(HOST_DIR)/include/netconfig.h
 endef