package/pkg-utils.mk: report the list of ignored CVEs in show-info
authorGregory CLEMENT <gregory.clement@bootlin.com>
Fri, 24 Jul 2020 15:43:51 +0000 (17:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Aug 2020 08:22:24 +0000 (10:22 +0200)
Add the list of the CVEs to ignore for each package because they
already have a fix for it.

This information will be useful for a cve-checker.

Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-utils.mk

index d88a14ab0f011a88c66c37554a37005002a0d12e..4fcb076e21d0594e1ad651f5ea0e7ed37f45c3d1 100644 (file)
@@ -119,6 +119,11 @@ define _json-info-pkg
        "reverse_dependencies": [
                $(call make-comma-list,$(sort $($(1)_RDEPENDENCIES)))
        ]
+       $(if $($(1)_IGNORE_CVES),
+               $(comma) "ignore_cves": [
+                       $(call make-comma-list,$(sort $($(1)_IGNORE_CVES)))
+               ]
+       )
 endef
 
 define _json-info-pkg-details