lighttpd: add optional pam support
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 10:21:52 +0000 (11:21 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 31 Oct 2018 09:23:11 +0000 (10:23 +0100)
Let the option depend on linux-pam as pam has quite some dependencies and
this is unlikely to be used if pam isn't explicitly enabled.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lighttpd/Config.in
package/lighttpd/lighttpd.mk

index 383c10f70f8cdfdedc91071d8d9abc861dad7850..0f37422aea007b345a7176587289737dd171295b 100644 (file)
@@ -26,6 +26,13 @@ config BR2_PACKAGE_LIGHTTPD_OPENSSL
        help
          Enable OpenSSL support for lighttpd.
 
+config BR2_PACKAGE_LIGHTTPD_PAM
+       bool "pam authentication support"
+       depends on BR2_PACKAGE_LINUX_PAM
+       default y
+       help
+         Enable PAM authentication support for lighttpd.
+
 config BR2_PACKAGE_LIGHTTPD_ZLIB
        bool "zlib support"
        select BR2_PACKAGE_ZLIB
index 44bee6f90f53217b64d8046f2d59ce83672e36d8..d8f64dc7e8f56942c5ae507b134547782b4da34e 100644 (file)
@@ -12,7 +12,6 @@ LIGHTTPD_LICENSE = BSD-3-Clause
 LIGHTTPD_LICENSE_FILES = COPYING
 LIGHTTPD_DEPENDENCIES = host-pkgconf
 LIGHTTPD_CONF_OPTS = \
-       --without-pam \
        --without-wolfssl \
        --libdir=/usr/lib/lighttpd \
        --libexecdir=/usr/lib
@@ -24,6 +23,13 @@ else
 LIGHTTPD_CONF_OPTS += --without-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_LIGHTTPD_PAM),y)
+LIGHTTPD_DEPENDENCIES += linux-pam
+LIGHTTPD_CONF_OPTS += --with-pam
+else
+LIGHTTPD_CONF_OPTS += --without-pam
+endif
+
 ifeq ($(BR2_PACKAGE_LIGHTTPD_ZLIB),y)
 LIGHTTPD_DEPENDENCIES += zlib
 LIGHTTPD_CONF_OPTS += --with-zlib