perl-gd: fix broken patches
authorFrancois Perrad <fperrad@gmail.com>
Sat, 19 Jul 2014 14:16:48 +0000 (16:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jul 2014 14:32:58 +0000 (16:32 +0200)
in each patch, the 3 trailing lines are lost

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perl-gd/perl-gd-01-getoptions.patch
package/perl-gd/perl-gd-02-lgd.patch
package/perl-gd/perl-gd-03-force.patch

index 7bd7f4f22d5c71cdf4cab044f2564e475ee08b43..74f055bead61cafef99997204957cb322afb22d1 100644 (file)
@@ -38,3 +38,6 @@ Index: b/Makefile.PL
 -                      "lib_xpm_path=s"  => \$lib_xpm_path,
 -                      "lib_zlib_path=s" => \$lib_zlib_path,
 -                     );
+ unless ($result) {
+   print STDERR <<END;
+ Usage: perl Makefile.PL [options]
index bc6cdfcc7a4041b2b93e41bad116d12d004de3e2..4a69c2ae8eef0fb4e1667376df7e596bc670a77b 100644 (file)
@@ -23,3 +23,6 @@ Index: b/Makefile.PL
    @$LIBS         = split /\s+/,$libs;
  
 -  push @$LIBS,"-lgd";
+   push @$LIBPATH,"-L$libdir";
+   ($$lib_gd_path = $libdir) =~ s!/[^/]+$!!;
+   $$options      = $features;
index 352486521d163732c4108eae7c84ea188593d826..0a121a994e625ca4574df886bf18302398110b11 100644 (file)
@@ -27,3 +27,6 @@ Index: b/Makefile.PL
 +    my @libs64 = map {my $a = $_; $a=~ s/lib$/lib64/; $a} @LIBPATH;
 +    @LIBPATH = (@LIBPATH,@libs64);
 +  }
+ }
+ #############################################################################################