package/dovecot: add optional support for xz
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 10 Feb 2016 20:58:18 +0000 (21:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Feb 2016 22:06:55 +0000 (23:06 +0100)
When xz was compiled before, dovecot will use it as optional dependency:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/lib/dovecot/lib30_imap_zlib_plugin.so | grep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [liblzma.so.5]
 0x00000001 (NEEDED)                     Shared library: [liblz4.so.1]
 0x00000001 (NEEDED)                     Shared library: [libc.so.1]

(lz4 support will be added with the next patch of this series)

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dovecot/dovecot.mk

index eea9efcc2fd90c6f76dc708382fce42b46f999e0..dbf2dab10660a0dbc45f3c7eb2fcdf3054bcf64e 100644 (file)
@@ -76,6 +76,13 @@ else
 DOVECOT_CONF_OPTS += --without-sqlite
 endif
 
+ifeq ($(BR2_PACKAGE_XZ),y)
+DOVECOT_CONF_OPTS += --with-lzma
+DOVECOT_DEPENDENCIES += xz
+else
+DOVECOT_CONF_OPTS += --without-lzma
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 DOVECOT_CONF_OPTS += --with-zlib
 DOVECOT_DEPENDENCIES += zlib