Makefile: let show-targets prints also the dependencies
authorFabio Porcedda <fabio.porcedda@gmail.com>
Wed, 23 Apr 2014 08:39:24 +0000 (10:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Apr 2014 22:20:36 +0000 (00:20 +0200)
Because the "show-targets" target print the targets that will be built,
print also their dependencies.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index fc111b38cd7e6d980df71894e77be8169f32fc82..eff408b4c572f66827cd62373a9a5d66439d1500 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -653,7 +653,7 @@ legal-info: dirs legal-info-clean legal-info-prepare $(TARGETS_LEGAL_INFO) \
        @rm -f $(LEGAL_WARNINGS)
 
 show-targets:
-       @echo $(TARGETS) $(TARGETS_ROOTFS)
+       @echo $(HOST_DEPS) $(TARGETS_HOST_DEPS) $(TARGETS) $(TARGETS_ROOTFS)
 
 graph-build: $(O)/build/build-time.log
        @install -d $(O)/graphs