package/connman: add iptables/nftables selection
authorPetr Vorel <petr.vorel@gmail.com>
Thu, 27 Feb 2020 23:29:54 +0000 (00:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Mar 2020 21:46:36 +0000 (22:46 +0100)
This allows to use nftables instead of the default iptables.

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/connman/Config.in
package/connman/connman.mk

index 30eae23c965ca3bdabf4b86165ab8dec38567435..ac012dda54c35f210245589ee8fe2488b2296628 100644 (file)
@@ -8,7 +8,6 @@ config BR2_PACKAGE_CONNMAN
        depends on !BR2_TOOLCHAIN_USES_MUSL # missing res_ninit()
        select BR2_PACKAGE_DBUS
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_IPTABLES
        help
          The Connection Manager (ConnMan) project provides a daemon
          for managing internet connections within embedded devices
@@ -18,6 +17,27 @@ config BR2_PACKAGE_CONNMAN
 
 if BR2_PACKAGE_CONNMAN
 
+choice
+       prompt "Firewall type"
+       default BR2_PACKAGE_CONNMAN_IPTABLES
+       help
+         Select which firewall type is used.
+
+config BR2_PACKAGE_CONNMAN_IPTABLES
+       bool "iptables"
+       select BR2_PACKAGE_IPTABLES
+       help
+         Use iptables as firewall.
+
+config BR2_PACKAGE_CONNMAN_NFTABLES
+       bool "nftables"
+       depends on BR2_USE_WCHAR
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
+       select BR2_PACKAGE_NFTABLES
+       help
+         Use nftables as firewall.
+endchoice
+
 config BR2_PACKAGE_CONNMAN_ETHERNET
        bool "enable Ethernet support"
        default y
index 7ea52f012a447f14dfa1e287e476615653a450a2..701be8b59d0d8b8dc3aac6c6f0a10a61f10bfc2a 100644 (file)
@@ -36,6 +36,14 @@ else
 CONNMAN_CONF_OPTS += --disable-ethernet
 endif
 
+ifeq ($(BR2_PACKAGE_CONNMAN_IPTABLES),y)
+CONNMAN_CONF_OPTS += --with-firewall=iptables
+CONNMAN_DEPENDENCIES += iptables
+else ifeq ($(BR2_PACKAGE_CONNMAN_NFTABLES),y)
+CONNMAN_CONF_OPTS += --with-firewall=nftables
+CONNMAN_DEPENDENCIES += nftables
+endif
+
 ifeq ($(BR2_PACKAGE_CONNMAN_LOOPBACK),y)
 CONNMAN_CONF_OPTS += --enable-loopback
 else