perf: disable documentation
authorArnout Vandecappelle <arnout@mind.be>
Wed, 23 Oct 2013 23:28:01 +0000 (01:28 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 24 Oct 2013 06:39:10 +0000 (08:39 +0200)
perf uses asciidoc to generate documentation, but /usr/bin/asciidoc will
try to use buildroot's host-python which doesn't have the required
unicodedata. Recent kernels always try to build the man pages when
installing. To avoid that, define ASCIIDOC as an empty string so the
Makefile can't find the executable and skips the documentation
generation.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/perf/perf.mk

index 120353f8e3c69bb1d701d73bd1d908fce02f5439..d7898d0bc392bd93fe8c09b19dc396e69447b7e1 100644 (file)
@@ -19,7 +19,8 @@ PERF_MAKE_FLAGS = \
        NO_LIBPYTHON=1 \
        DESTDIR=$(TARGET_DIR) \
        prefix=/usr \
-       WERROR=0
+       WERROR=0 \
+       ASCIIDOC=
 
 ifeq ($(BR2_PACKAGE_ELFUTILS),y)
        PERF_DEPENDENCIES += elfutils