linenoise: install nothing on target
authorFrancois Perrad <fperrad@gmail.com>
Tue, 9 Sep 2014 18:15:43 +0000 (20:15 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 9 Sep 2014 21:06:26 +0000 (23:06 +0200)
linenoise is a static library, so it's enough to install on staging.
and the linenoise_example executable is not really useful.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linenoise/linenoise.mk

index 562b445af1d3ffd0795792c9d84b6ceffe7647e9..aff0c7d384d141d87c94877df78e8aeb923ac80e 100644 (file)
@@ -8,6 +8,8 @@ LINENOISE_VERSION = 828b9dacc52d4ad5a15c89be8fb8691d224f9a4f
 LINENOISE_SITE = $(call github,antirez,linenoise,$(LINENOISE_VERSION))
 LINENOISE_LICENSE = BSD-2c
 LINENOISE_INSTALL_STAGING = YES
+# Static library only, nothing to install on target
+LINENOISE_INSTALL_TARGET = NO
 
 define LINENOISE_BUILD_CMDS
        cd $(@D); $(TARGET_CC) $(TARGET_CFLAGS) -c linenoise.c
@@ -21,10 +23,4 @@ define LINENOISE_INSTALL_STAGING_CMDS
        $(INSTALL) -m 755 -D $(@D)/linenoise_example    $(STAGING_DIR)/usr/bin/linenoise_example
 endef
 
-define LINENOISE_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 644 -D $(@D)/linenoise.h          $(TARGET_DIR)/usr/include/linenoise.h
-       $(INSTALL) -m 644 -D $(@D)/liblinenoise.a       $(TARGET_DIR)/usr/lib/liblinenoise.a
-       $(INSTALL) -m 755 -D $(@D)/linenoise_example    $(TARGET_DIR)/usr/bin/linenoise_example
-endef
-
 $(eval $(generic-package))