vlc: workaround microblaze gcc internal compiler error
authorWaldemar Brodkorb <wbx@openadk.org>
Mon, 27 Feb 2017 06:07:25 +0000 (07:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Feb 2017 20:35:46 +0000 (21:35 +0100)
Override gcc optimization flags with -O0. The workaround is not required
for gcc6 anymore, so we take this into account into our condition.

Fixes:

  http://autobuild.buildroot.net/results/a318f0838a6a602046e719103ac81965c0084d52

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
[Thomas: add gcc 6.x condition.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index 666b8d4bf5bdc16d9102a706ba76fa02987e6af9..583edf3659ac0a8a202e3a41eff2ec2dc75add27 100644 (file)
@@ -15,6 +15,13 @@ VLC_AUTORECONF = YES
 # Install vlc libraries in staging.
 VLC_INSTALL_STAGING = YES
 
+# gcc bug internal compiler error: in merge_overlapping_regs, at
+# regrename.c:304. This bug is fixed since gcc 6.
+ifeq ($(BR2_microblaze):$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),y:)
+VLC_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -O0"
+VLC_CONF_OPTS += --disable-optimizations
+endif
+
 # VLC defines two autoconf functions which are also defined by our own pkg.m4
 # from pkgconf. Unfortunately, they are defined in a different way: VLC adds
 # --enable- options, but pkg.m4 adds --with- options. To make sure we use