webkitgtk24: depend on x11 backend for gtk3
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 3 Aug 2015 11:06:22 +0000 (08:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2015 09:27:33 +0000 (11:27 +0200)
The other rendering backends aren't supported right now, so depend on
the X11 one to avoid build breakage. Fixes:
http://autobuild.buildroot.net/results/1b3/1b372dd04eaccd8a9d24390d509b0a49f692746c/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webkitgtk24/webkitgtk24.mk

index 5c1bb5baa7aafa44bd9d391bc5dc70bc4eae3839..a58fed37beae873afcc3341409a49810df4dd427 100644 (file)
@@ -101,7 +101,7 @@ endif
 # webkit1 (old API) uses gtk2, webkit2 (new API) uses gtk3
 # Both can be built simultaneously, prefer "newer" for size/time savings
 # gtk2 is mandatory for plugin support
-ifeq ($(BR2_PACKAGE_LIBGTK3),y)
+ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
 WEBKITGTK24_CONF_OPTS += \
        --with-gtk=3.0 \
        --disable-webkit1